import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/yandex\\.ru\\/\\w+\\/\\w+\\/\\w+\\/(\\w+)$";
final String string = "https://yandex.ru/aaaaa/ggg/TARGET/uuuuuu\n"
+ "https://yandex.ru/bbbb/kkkk/TARGET/mmmm\n"
+ "https://yandex.ru/ccccc/eeee/TARGET/nnnnnn";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}