package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https:\/\/yandex\.ru\/\w+\/\w+\/\w+\/(\w+)$`)
var str = `https://yandex.ru/aaaaa/ggg/TARGET/uuuuuu
https://yandex.ru/bbbb/kkkk/TARGET/mmmm
https://yandex.ru/ccccc/eeee/TARGET/nnnnnn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}