package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|[^a-z])month`)
var str = `startmonth month +month`
var substitution = "\112"
fmt.Println(re.ReplaceAllString(str, substitution))
}