use strict;
my $str = 'startmonth month +month';
my $regex = qr/(^|[^a-z])month/mp;
my $subst = '\\112';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";