import Foundation
let pattern = #"(^|[^a-z])month"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"startmonth month +month"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\112"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)