const regex = /(^|[^a-z])month/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^a-z])month', 'gm')
const str = `startmonth month +month`;
const subst = `\112`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);