# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!0)(\d)(?!\d)$/0$1/gm;t' <<< "File_20
File_19
File_2
File_3
File_4"