import Foundation
let pattern = #"(?!0)(\d)(?!\d)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
File_20
File_19
File_2
File_3
File_4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)