using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!0)(\d)(?!\d)$";
string substitution = @"0$1";
string input = @"File_20
File_19
File_2
File_3
File_4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}