$re = '/(?!0)(\d)(?!\d)$/m';
$str = 'File_20
File_19
File_2
File_3
File_4';
$subst = "0$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;