#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!0)(\d)(?!\d)$"
Local $sString = "File_20" & @CRLF & _
"File_19" & @CRLF & _
"File_2" & @CRLF & _
"File_3" & @CRLF & _
"File_4"
Local $sSubst = "0$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)