import re
regex = re.compile(r"(?!0)(\d)(?!\d)$", flags=re.MULTILINE)
test_str = ("File_20\n"
"File_19\n"
"File_2\n"
"File_3\n"
"File_4")
subst = "0$1"
result = regex.sub(subst, test_str)
if result:
print(result)