#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w)\1?(\1*)"
Local $sString = "abc" & @CRLF & _
"yahoo" & @CRLF & _
"opinion" & @CRLF & _
"aaaaaabc" & @CRLF & _
"" & @CRLF & _
"abc" & @CRLF & _
"aabbcc" & @CRLF & _
"aaabbbccc" & @CRLF & _
"aaaaaa" & @CRLF & _
"aaaa"
Local $sSubst = "$1$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)