re = /(\w)\1?(\1*)/m
str = 'abc
yahoo
opinion
aaaaaabc
abc
aabbcc
aaabbbccc
aaaaaa
aaaa'
subst = '$1$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result