using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w)\1?(\1*)";
string substitution = @"$1$1$2";
string input = @"abc
yahoo
opinion
aaaaaabc
abc
aabbcc
aaabbbccc
aaaaaa
aaaa";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}