import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w)\\1?(\\1*)";
final String string = "abc\n"
+ "yahoo\n"
+ "opinion\n"
+ "aaaaaabc\n\n"
+ "abc\n"
+ "aabbcc\n"
+ "aaabbbccc\n"
+ "aaaaaa\n"
+ "aaaa";
final String subst = "$1$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}