use strict;
my $str = 'abc
yahoo
opinion
aaaaaabc
abc
aabbcc
aaabbbccc
aaaaaa
aaaa';
my $regex = qr/(\w)\1?(\1*)/mp;
my $subst = '$1$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";