$re = '/(\w)\1?(\1*)/m';
$str = 'abc
yahoo
opinion
aaaaaabc
abc
aabbcc
aaabbbccc
aaaaaa
aaaa';
$subst = "$1$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;