# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:(?:(?:\d+-\d+\\/\d+|\d+(?:[-,\\/]\d+)?|\*\\/\d+)(?:,(?:\d+-\d+\\/\d+|\d+(?:[-,\\/]\d+)?|\*\\/\d+))*)|\*)$//gm;t' <<< "MATCH
1,2,3
1,2
1/2
1-2
0-2,7
1
*
0,*/3,6-1/20
NO MATCH
*
*-*
//
1-
1,
1-4,
1-1/
//*
1,*
1-*
1-4,*
1-1/*
^(?:
(?:
(?:
\d+-\d+\/\d+ |
\d+(?:[-,/]\d+)? |
\*\/\d+
)
(?:
,(?:
\d+-\d+\/\d+ |
\d+(?:[-,/]\d+)? |
\*\/\d+
)
)*
) |
\*
)$
"