import Foundation
let pattern = #"^(?:(?:(?:\d+-\d+\/\d+|\d+(?:[-,\/]\d+)?|\*\/\d+)(?:,(?:\d+-\d+\/\d+|\d+(?:[-,\/]\d+)?|\*\/\d+))*)|\*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MATCH
1,2,3
1,2
1/2
1-2
0-2,7
1
*
0,*/3,6-1/20
NO MATCH
*
*-*
//
1-
1,
1-4,
1-1/
//*
1,*
1-*
1-4,*
1-1/*
^(?:
(?:
(?:
\d+-\d+\/\d+ |
\d+(?:[-,/]\d+)? |
\*\/\d+
)
(?:
,(?:
\d+-\d+\/\d+ |
\d+(?:[-,/]\d+)? |
\*\/\d+
)
)*
) |
\*
)$
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)