use strict;
my $str = 'MATCH
1,2,3
1,2
1/2
1-2
0-2,7
1
*
0,*/3,6-1/20
NO MATCH
*
*-*
//
1-
1,
1-4,
1-1/
//*
1,*
1-*
1-4,*
1-1/*
^(?:
(?:
(?:
\\d+-\\d+\\/\\d+ |
\\d+(?:[-,/]\\d+)? |
\\*\\/\\d+
)
(?:
,(?:
\\d+-\\d+\\/\\d+ |
\\d+(?:[-,/]\\d+)? |
\\*\\/\\d+
)
)*
) |
\\*
)$
';
my $regex = qr/^(?:(?:(?:\d+-\d+\/\d+|\d+(?:[-,\/]\d+)?|\*\/\d+)(?:,(?:\d+-\d+\/\d+|\d+(?:[-,\/]\d+)?|\*\/\d+))*)|\*)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";