$re = '/^(?:(?:(?:\d+-\d+\/\d+|\d+(?:[-,\/]\d+)?|\*\/\d+)(?:,(?:\d+-\d+\/\d+|\d+(?:[-,\/]\d+)?|\*\/\d+))*)|\*)$/m';
$str = 'MATCH
1,2,3
1,2
1/2
1-2
0-2,7
1
*
0,*/3,6-1/20
NO MATCH
*
*-*
//
1-
1,
1-4,
1-1/
//*
1,*
1-*
1-4,*
1-1/*
^(?:
(?:
(?:
\\d+-\\d+\\/\\d+ |
\\d+(?:[-,/]\\d+)? |
\\*\\/\\d+
)
(?:
,(?:
\\d+-\\d+\\/\\d+ |
\\d+(?:[-,/]\\d+)? |
\\*\\/\\d+
)
)*
) |
\\*
)$
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;