using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:(?:\d+-\d+\/\d+|\d+(?:[-,\/]\d+)?|\*\/\d+)(?:,(?:\d+-\d+\/\d+|\d+(?:[-,\/]\d+)?|\*\/\d+))*)|\*)$";
string substitution = @"";
string input = @"MATCH
1,2,3
1,2
1/2
1-2
0-2,7
1
*
0,*/3,6-1/20
NO MATCH
*
*-*
//
1-
1,
1-4,
1-1/
//*
1,*
1-*
1-4,*
1-1/*
^(?:
(?:
(?:
\d+-\d+\/\d+ |
\d+(?:[-,/]\d+)? |
\*\/\d+
)
(?:
,(?:
\d+-\d+\/\d+ |
\d+(?:[-,/]\d+)? |
\*\/\d+
)
)*
) |
\*
)$
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}