#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:(?:(?:\d+-\d+\/\d+|\d+(?:[-,\/]\d+)?|\*\/\d+)(?:,(?:\d+-\d+\/\d+|\d+(?:[-,\/]\d+)?|\*\/\d+))*)|\*)$"
Local $sString = "MATCH" & @CRLF & _
"" & @CRLF & _
"1,2,3" & @CRLF & _
"1,2" & @CRLF & _
"1/2" & @CRLF & _
"1-2" & @CRLF & _
"0-2,7" & @CRLF & _
"1" & @CRLF & _
"*" & @CRLF & _
"0,*/3,6-1/20" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"NO MATCH" & @CRLF & _
"" & @CRLF & _
" *" & @CRLF & _
"*-*" & @CRLF & _
"//" & @CRLF & _
"1-" & @CRLF & _
"1," & @CRLF & _
"1-4," & @CRLF & _
"1-1/" & @CRLF & _
"//*" & @CRLF & _
"1,*" & @CRLF & _
"1-*" & @CRLF & _
"1-4,*" & @CRLF & _
"1-1/*" & @CRLF & _
"" & @CRLF & _
"^(?:" & @CRLF & _
"(?:" & @CRLF & _
" (?:" & @CRLF & _
" \d+-\d+\/\d+ |" & @CRLF & _
" \d+(?:[-,/]\d+)? |" & @CRLF & _
" \*\/\d+ " & @CRLF & _
" )" & @CRLF & _
" (?:" & @CRLF & _
"" & @CRLF & _
" ,(?: " & @CRLF & _
" \d+-\d+\/\d+ |" & @CRLF & _
" \d+(?:[-,/]\d+)? |" & @CRLF & _
" \*\/\d+ " & @CRLF & _
"" & @CRLF & _
" )" & @CRLF & _
" )*" & @CRLF & _
") |" & @CRLF & _
"\*" & @CRLF & _
")$" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)