# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w)([ ]*)(\[\d+])/$1 $3/gm;t' <<< "avc[123]
avc [123]
avc [123]
avc [123]
avcd[12345]
[123]
avc[123
avc123
avc"