import Foundation
let pattern = #"(\w)([ ]*)(\[\d+])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
avc[123]
avc [123]
avc [123]
avc [123]
avcd[12345]
[123]
avc[123
avc123
avc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)