const regex = /(\w)([ ]*)(\[\d+])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w)([ ]*)(\\[\\d+])', 'gm')
const str = `avc[123]
avc [123]
avc [123]
avc [123]
avcd[12345]
[123]
avc[123
avc123
avc`;
const subst = `$1 $3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);