# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w)([ ]*)(\[\d+])"
test_str = ("avc[123]\n"
"avc [123]\n"
"avc [123]\n"
"avc [123]\n"
"avcd[12345]\n"
"[123]\n"
"avc[123\n"
"avc123\n"
"avc")
subst = "$1 $3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.