package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w)([ ]*)(\[\d+])`)
var str = `avc[123]
avc [123]
avc [123]
avc [123]
avcd[12345]
[123]
avc[123
avc123
avc`
var substitution = "$1 $3"
fmt.Println(re.ReplaceAllString(str, substitution))
}