import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w)([ ]*)(\\[\\d+])";
final String string = "avc[123]\n"
+ "avc [123]\n"
+ "avc [123]\n"
+ "avc [123]\n"
+ "avcd[12345]\n"
+ "[123]\n"
+ "avc[123\n"
+ "avc123\n"
+ "avc";
final String subst = "$1 $3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}