#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\!-\/\:-\@\[-\`\{-\~])(?:.{8})$"
Local $sString = "*** NOT MATCH" & @CRLF & _
"abc" & @CRLF & _
"abc123" & @CRLF & _
"abC12312" & @CRLF & _
"123Abc!!d" & @CRLF & _
"*** MATCH" & @CRLF & _
"1Ab@1Ab@" & @CRLF & _
"%D123!cc" & @CRLF & _
"" & @CRLF & _
"# ### NOTES" & @CRLF & _
"# - 8 characters long" & @CRLF & _
"# - Must include capital letters" & @CRLF & _
"# - Must include small letters" & @CRLF & _
"# - Must include numbers" & @CRLF & _
"# - Must include special characters" & @CRLF & _
"# - NOTE: Can also use [[:punct:]] for special characters but it may not be supported by your regex engine." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")