using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\!-\/\:-\@\[-\`\{-\~])(?:.{8})$";
string input = @"*** NOT MATCH
abc
abc123
abC12312
123Abc!!d
*** MATCH
1Ab@1Ab@
%D123!cc
# ### NOTES
# - 8 characters long
# - Must include capital letters
# - Must include small letters
# - Must include numbers
# - Must include special characters
# - NOTE: Can also use [[:punct:]] for special characters but it may not be supported by your regex engine.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}