$re = '/^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\!-\/\:-\@\[-\`\{-\~])(?:.{8})$/m';
$str = '*** NOT MATCH
abc
abc123
abC12312
123Abc!!d
*** MATCH
1Ab@1Ab@
%D123!cc
# ### NOTES
# - 8 characters long
# - Must include capital letters
# - Must include small letters
# - Must include numbers
# - Must include special characters
# - NOTE: Can also use [[:punct:]] for special characters but it may not be supported by your regex engine.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);