import Foundation
let pattern = #"^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\!-\/\:-\@\[-\`\{-\~])(?:.{8})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ####"""
*** NOT MATCH
abc
abc123
abC12312
123Abc!!d
*** MATCH
1Ab@1Ab@
%D123!cc
# ### NOTES
# - 8 characters long
# - Must include capital letters
# - Must include small letters
# - Must include numbers
# - Must include special characters
# - NOTE: Can also use [[:punct:]] for special characters but it may not be supported by your regex engine.
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)