const regex = /^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\!-\/\:-\@\[-\`\{-\~])(?:.{8})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\\!-\\\/\\:-\\@\\[-\\`\\{-\\~])(?:.{8})$', 'gm')
const str = `*** NOT MATCH
abc
abc123
abC12312
123Abc!!d
*** MATCH
1Ab@1Ab@
%D123!cc
# ### NOTES
# - 8 characters long
# - Must include capital letters
# - Must include small letters
# - Must include numbers
# - Must include special characters
# - NOTE: Can also use [[:punct:]] for special characters but it may not be supported by your regex engine.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}