import re
regex = re.compile(r"^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[\!-\/\:-\@\[-\`\{-\~])(?:.{8})$", flags=re.MULTILINE)
test_str = ("*** NOT MATCH\n"
"abc\n"
"abc123\n"
"abC12312\n"
"123Abc!!d\n"
"*** MATCH\n"
"1Ab@1Ab@\n"
"%D123!cc\n\n"
"# ### NOTES\n"
"# - 8 characters long\n"
"# - Must include capital letters\n"
"# - Must include small letters\n"
"# - Must include numbers\n"
"# - Must include special characters\n"
"# - NOTE: Can also use [[:punct:]] for special characters but it may not be supported by your regex engine.\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")