# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\s*\w+)+|(?:\s*[\u0590-\u05FF]+)+?(?=\s?[A-Za-z0-9!?.]))/<span>$1<\/span>/gi;t' <<< "so היי all whats up אתכם אתכם test היי?"