import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\s*\\w+)+|(?:\\s*[\\u0590-\\u05FF]+)+?(?=\\s?[A-Za-z0-9!?.]))";
final String string = "so היי all whats up אתכם אתכם test היי?";
final String subst = "<span>$1</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}