use strict;
my $str = 'so היי all whats up אתכם אתכם test היי?';
my $regex = qr/((?:\s*\w+)+|(?:\s*[\u0590-\u05FF]+)+?(?=\s?[A-Za-z0-9!?.]))/ip;
my $subst = '<span>$1</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";