import Foundation
let pattern = #"((?:\s*\w+)+|(?:\s*[\u0590-\u05FF]+)+?(?=\s?[A-Za-z0-9!?.]))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"so היי all whats up אתכם אתכם test היי?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span>$1</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)