$re = '/((?:\s*\w+)+|(?:\s*[\u0590-\u05FF]+)+?(?=\s?[A-Za-z0-9!?.]))/i';
$str = 'so היי all whats up אתכם אתכם test היי?';
$subst = "<span>$1</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;