const regex = /((?:\s*\w+)+|(?:\s*[\u0590-\u05FF]+)+?(?=\s?[A-Za-z0-9!?.]))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\s*\\w+)+|(?:\\s*[\\u0590-\\u05FF]+)+?(?=\\s?[A-Za-z0-9!?.]))', 'gi')
const str = `so היי all whats up אתכם אתכם test היי?`;
const subst = `<span>$1</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);