# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[(([^][]|\[([^][]|\[[^][]*\])*\])*)\]/{\1}/g;t' <<< "{0,0,0,[12,2],0,0,[12,[1,2,3]],12,0,[12,2,[2]],12,0,12,0,0}"