import re
regex = re.compile(r"\[(([^][]|\[([^][]|\[[^][]*\])*\])*)\]")
test_str = "{0,0,0,[12,2],0,0,[12,[1,2,3]],12,0,[12,2,[2]],12,0,12,0,0}"
subst = "{\\1}"
result = regex.sub(subst, test_str)
if result:
print(result)