const regex = /\[(([^][]|\[([^][]|\[[^][]*\])*\])*)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(([^][]|\\[([^][]|\\[[^][]*\\])*\\])*)\\]', 'g')
const str = `{0,0,0,[12,2],0,0,[12,[1,2,3]],12,0,[12,2,[2]],12,0,12,0,0}`;
const subst = `{\1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);