$re = '/\[(([^][]|\[([^][]|\[[^][]*\])*\])*)\]/';
$str = '{0,0,0,[12,2],0,0,[12,[1,2,3]],12,0,[12,2,[2]],12,0,12,0,0}';
$subst = "{\1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;