using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)\s+(?=\d)|\+(?=\d)";
string substitution = @"";
string input = @"hello +70 888 777 1 1 3 thisa ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}