re = /(?<=\d)\s+(?=\d)|\+(?=\d)/
str = 'hello +70 888 777 1 1 3 thisa '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result