use strict;
my $str = 'hello +70 888 777 1 1 3 thisa ';
my $regex = qr/(?<=\d)\s+(?=\d)|\+(?=\d)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";