$re = '/(?<=\d)\s+(?=\d)|\+(?=\d)/';
$str = 'hello +70 888 777 1 1 3 thisa ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;